Probleme bei Firmware

  • Guten Tag Zusammen


    Ich habe seit kurzer Zeit einen DiY 3I mit einem Anet Board.

    Nach längerem durchforsten des internets wuste ich das ich die Firmware aktualiesieren möchte.

    Also habe ich mich informiert wie ich dies machen muss.

    Arduino instaliert und Marlin darin geladen anpasungen gemacht. Dies war alles kein problem aber wen ich jetzt das aufs Board laden will kommt eine meldung und ich weis nicht mehr weiter auch nach dem das ich im Internet und auch hier im Forum mich informieren wolte habe ich keinen anhaltspunkt was ich machen soll.

    Die Meldung von Arduino sieht volgendermasen aus:

    Ich habe schon so sachen gelesen wie ich müsse den Bordloder neu brennen aber dies ist ja nur mit hilfe eines weideren Boards möglich und dies habe ich nicht oder gibt es eine andere variante das ich Marlin aufs Board bekomme?


    Ich hoffe ich habe euch alle erforderliche infos angegeben sonst gebe ich gerne weitere angaben an.

    Ich hoffe ihr könnt mir helfen.


    Danke schon mal im voraus für eure Hilfe.


    LG Myrddin

  • Ja, bei nem Klon des roten Anet-Boards (CTC verschickt nen Klon) muss man auf 57600 Baud umstellen, wie Hubert völlig richtig sagt.
    Wenn das nicht hilft, hilft nur ein FTDI oder Atmega Adapter zum Brennen des Bootloaders..

    Klickibunti ? Nein Danke. Ich versteh lieber, was ich tu...

  • Hallo Zusammen


    Danke für die Antworten. Ich habe dies versucht aber ging auch nicht also bleibt mir nur noch ein Board zu kaufen um den bootloader zu brennen. Jetzt bin ich am überlegen welches habe schon gehört das man da verschiedene nehmen kann. Oliver hat ja schon 2 aufgezählt und habe auch schon von arduino uno gehört oder das sie raspberry pi verwenden gieb es dabei grosse Unterschiede? Wen ich schon was kaufe möchte ich es nicht nur 1 mal gebrauchen. Kenne mich aber dabei nicht aus ist Neuland für mich.


    Hoffe zerstöre nich was.


    Lg und Danke

    Myrddin

  • Bist du sicher, dass du in Boards.txt, den richtigen Eintrag geändert hast?
    Es ist schon nicht so einfach die Datei boards.txt zu finden.
    Wenn du Arduino aus dem Windows store installiert hast, musst du z.B. erst die Berechtigungen vom WindowsApps Ordner ändern um an die Datei zu kommen.
    Bei einigen Installationen ist sie im Installationsordner, bei anderen in appdata local arduino, oder sogar auf onedrive, am besten die Datei mit der Windows Suchfunktion finden.
    Bei mir steht es im Ordner C:\Program Files (x86)\Arduino\hardware\arduino\avr
    Dann musst du die Baudrate (uploadspeed) für den ArduinoMega für den richtigen Controller ändern.
    Es geht um den Abschnitt:
    "mega.name=Arduino/Genuino Mega or Mega 2560"

    und den Eintrag "mega.menu.cpu.atmega2560.upload.speed=115200"

    oder wenn eie atmega1280 verbaut ist
    "mega.menu.cpu.atmega1280.upload.speed=57600"

    Das richtige Board muss natürlich auch in der Arduino IDE unter Werkzeuge Board eingestellt sein.

    Richtig ist hier Arduino/Genuino Mega or Mega2560, danach muss dann och der richtige Arduino (2560 oder1280= augewählt werden.

    The post was edited 1 time, last by Hubert ().

  • Anzeige:
  • Guten Tag


    Ja ich habe sehrwascheinlich wie Hubert gesagt hat die Falsche Datei verändert.

    Mir ist ein Misgeschik pasiert ich habe aus versehen das Aduino Deistaliert. Also habe ich es wieder istaliert und noch mal von vorne begonnen.

    Ich habe jetzt noch mal versucht die Marlin zu kontrolieren jetzt kommt diese Fehlermeldung. Ich glaube ich bin einfach zu blöde um dies zu schafen.

    Ich habe gesehen das auf meinem Anet Board ein Chipp verbaut ist mir der bezeichnung ATmega1284P was hat dies zu bedeuten weil dies ist ja auch in meiner Fehlermeldung aufgeführt.


    Gibt es irgend wo eine anleitung für dumis wie mich zb YouTube ?


    Ich danke für eure mühe und bin mich ein wenig am schämen.


    LG Myrddin

  • Der Chip bedeutet du hast einen Arduino Genuino Mega mit ATMEGA 1280.

    Also musst du die Baudrate hier >> "mega.menu.cpu.atmega1280.upload.speed=57600"<< einstellen.

    Die Datei die du (mit einem Texteditor, ich benutze Geany) bearbeiten musst ist die Boards.txt, nicht eine Datei aus Marlin, die Boards.txt findest du meistens unter C:\Program Files (x86)\Arduino\hardware\arduino\avr
    Was dort geändert werden muss, steht im vorherigen Post.

    The post was edited 1 time, last by Hubert ().

  • Wenn ich nachher daheim bin, mach ich dir Screenshots, was du wo genau auswählen musst.
    Du musst einfach noch mehrere Sachen in Arduino richtig einstellen und einrichten. Bei den Bibliotheken musst du die U8Glib installieren, beim Bootloader den Optiboot auswählen und in der Boards.txt die Baudrate auf 57600 setzen, wie bereits beschrieben.

    Klickibunti ? Nein Danke. Ich versteh lieber, was ich tu...

  • Guten Abend

    Danke schon mal für eure Hilfe.

    Ich habe jetzt alles genau nach eurer Hilfe gemacht. Alles klapt bis zum Hochladen. Ich gehe dafon aus das ich den bootloader neu brennen müste. Das heist ich muss mir irgend ein Board bestellen zb arduino uno.

    Aber an dies wage ich mich noch nicht und muss mir ein wenig Geld sparen für so einen board.

    Danke noch mals für eure Hilfe.

    LG Myrddin

  • Anzeige:
  • Ich habe mein letztes gelt für den Drucker ausgegeben. Nächsten Monat kann ich mir was kaufen. Muss schauen von wo ich mir dies kaufe weil ich aus der Schweiz komme. Vieleicht über ein online-shop.

    • Gäste Informationen
    Hallo. Gefällt Dir dieses Thema im CTC-Forum und du möchtest etwas dazu schreiben? Dann melde dich bitte an. Hast du noch kein Benutzerkonto im CTC-Forum, dann registriere dich bitte. Nach der Freischaltung kannst Du dann das Forum uneingeschränkt benutzen.


Werde Teil des Forums.

Hallo. Gefällt Dir das CTC-Forum und du möchtest mitmachen? Dann melde dich bitte an. Hast du noch kein Benutzerkonto im CTC-Forum, dann registriere dich bitte. Nach der Freischaltung kannst Du dann das Forum uneingeschränkt benutzen.